En resumen
- CVE-2022-29190 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a github.com/pion/dtls, github.com/pion/dtls/v2, dtls (pion).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.7%, mayor que el 77.9% de las vulnerabilidades.
- Solución: actualizar a 2.1.4 o posterior.
Description
Impact
An attacker can send packets that will send Pion DTLS into an infinite loop when processing.
Patches
Upgrade to Pion DTLS v2.1.4
Workarounds
No workarounds available, upgrade to Pion DTLS v2.1.4
References
Thank you to Juho Nurminen and the Mattermost team for discovering and reporting this.
For more information
If you have any questions or comments about this advisory:
NVD description
Pion DTLS is a Go implementation of Datagram Transport Layer Security. Prior to version 2.1.4, an attacker can send packets that sends Pion DTLS into an infinite loop when processing. Version 2.1.4 contains a patch for this issue. There are currently no known workarounds available.
Más vulnerabilidades de github.com/pion/dtls
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free