En resumen
- CVE-2022-31070 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a nestjs-proxy (finastra), nestjs-proxy (nestjs-proxy project), @finastra/nestjs-proxy.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.66%, mayor que el 51.7% de las vulnerabilidades.
- Solución: actualizar a 0.7.0 o posterior.
Description
The nestjs-proxy library did not have a way to block sensitive cookies (e.g. session cookies) from being forwarded to backend services configured by the application developer. This could have led to sensitive cookies being inadvertently exposed to such services that should not see them.
The patched version now blocks cookies from being forwarded by default. However developers can configure an allow-list of cookie names by using the allowedCookies config setting. Further details of this feature can be found in the library's README on Github or NPM.
Patches
- This issue has been fixed in version 0.7.0 of
@finastra/nestjs-proxy.
- Users of
@ffdc/nestjs-proxy are advised that this package has been deprecated and is no longer being maintained or receiving updates. Please update your package.json file to use @finastra/nestjs-proxy instead.
References
NVD description
NestJS Proxy is a NestJS module to decorate and proxy calls. Prior to version 0.7.0, the nestjs-proxy library did not have a way to block sensitive cookies (e.g. session cookies) from being forwarded to backend services configured by the application developer. This could have led to sensitive cookies being inadvertently exposed to such services that should not see them. The patched version now blocks cookies from being forwarded by default. However developers can configure an allow-list of cookie names by using the `allowedCookies` config setting. This issue has been fixed in version 0.7.0 of `@finastra/nestjs-proxy`. Users of `@ffdc/nestjs-proxy` are advised that this package has been deprecated and is no longer being maintained or receiving updates. Such users should update their package.json file to use `@finastra/nestjs-proxy` instead.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free