En resumen
- CVE-2022-31147 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a jquery validation (jqueryvalidation), jquery-validation.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.2%, mayor que el 82.9% de las vulnerabilidades.
- Solución: actualizar a 1.19.5 o posterior.
Description
Summary
Incomplete fix of CVE-2021-43306: An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the jquery-validation npm package, when an attacker is able to supply arbitrary input to the url2 method.
NVD description
The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.
Más vulnerabilidades de jquery validation
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free