En resumen
- CVE-2022-31191 es una vulnerabilidad MEDIO (CVSS 6.1) que afecta a org.dspace:dspace-jspui, dspace (duraspace).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.81%, mayor que el 57.0% de las vulnerabilidades.
- Solución: actualizar a 5.11, 6.4 o posterior.
Description
Impact
The JSPUI spellcheck "Did you mean" HTML escapes the data-spell attribute in the link, but not the actual displayed text. Similarly, the JSPUI autocomplete HTML does not properly escape text passed to it. Both are vulnerable to XSS. This vulnerability only impacts the JSPUI.
This vulnerability does NOT impact the XMLUI or 7.x.
Patches
DSpace 6.x:
- Fixed in 6.4 via two commits:
- 6.x patch files available (may be applied manually if an immediate upgrade to 6.4 or above is not possible)
DSpace 5.x:
- Fixed in 5.11 via two commits:
- 5.x patch files available (may be applied manually if an immediate upgrade to 5.11 or 6.4 is not possible)
Apply the patch to your DSpace
If at all possible, we recommend upgrading your DSpace site based on the upgrade instructions. However, if you are unable to do so, you can manually apply the above patches as follows:
- Download the appropriate patch file to the machine where DSpace is running
- From the
[dspace-src] folder, apply the patch, e.g. git apply [name-of-file].patch
- Now, update your DSpace site (based loosely on the Upgrade instructions). This generally involves three steps:
- Rebuild DSpace, e.g.
mvn -U clean package (This will recompile all DSpace code)
- Redeploy DSpace, e.g.
ant update (This will copy all updated WARs / configs to your installation directory). Depending on your setup you also may need to copy the updated WARs over to your Tomcat webapps folder.
- Restart Tomcat
References
Discovered & reported by Hassan Bhuiyan (Brunel University London)
For more information
If you have any questions or comments about this advisory:
NVD description
DSpace open source software is a repository application which provides durable access to digital resources. dspace-jspui is a UI component for DSpace. The JSPUI spellcheck "Did you mean" HTML escapes the data-spell attribute in the link, but not the actual displayed text. Similarly, the JSPUI autocomplete HTML does not properly escape text passed to it. Both are vulnerable to XSS. This vulnerability only impacts the JSPUI. Users are advised to upgrade. There are no known workarounds for this issue.
Más vulnerabilidades de org.dspace:dspace-jspui
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free