En resumen
- CVE-2022-36031 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a directus (monospace), directus.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.97%, mayor que el 61.9% de las vulnerabilidades.
- Solución: actualizar a 9.15.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| directus | < 9.15.0
| 9.15.0
|
| directus npm | < 9.15.0
| 9.15.0
|
Description
The Directus process can be aborted by having an authorized user update the filename_disk value to a folder and accessing that file through the /assets endpoint.
The vulnerability is patched and released in v9.15.0.
You can prevent this problem by making sure no (untrusted) non-admin users have permissions to update the filename_disk field on directus_files.
For more information
If you have any questions or comments about this advisory:
Credits
This vulnerability was first discovered and reported by Witold Gorecki.
NVD description
Directus is a free and open-source data platform for headless content management. The Directus process can be aborted by having an authorized user update the `filename_disk` value to a folder and accessing that file through the `/assets` endpoint. This vulnerability has been patched and release v9.15.0 contains the fix. Users are advised to upgrade. Users unable to upgrade may prevent this problem by making sure no (untrusted) non-admin users have permissions to update the `filename_disk` field on `directus_files`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free