En resumen
- CVE-2022-39267 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a github.com/brokercap/Bifrost, bifrost (xbifrost).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.90%, mayor que el 59.9% de las vulnerabilidades.
- Solución: actualizar a 1.8.7-release o posterior.
Description
Impact
The admin and monitor user groups need to be authenticated by username and password. If we delete the X-Requested-With: XMLHttpRequest field in the request header,the authentication will be bypassed.
Patches
https://github.com/brockercap/Bifrost/pull/201
Workarounds
Upgrade to the latest version
NVD description
Bifrost is a heterogeneous middleware that synchronizes MySQL, MariaDB to Redis, MongoDB, ClickHouse, MySQL and other services for production environments. Versions prior to 1.8.8-release are subject to authentication bypass in the admin and monitor user groups by deleting the X-Requested-With: XMLHttpRequest field in the request header. This issue has been patched in 1.8.8-release. There are no known workarounds.
Más vulnerabilidades de github.com/brokercap/Bifrost
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free