En resumen
- CVE-2022-39379 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a fluentd, fluentd (fluentd).
- Probabilidad de explotación en los próximos 30 días (EPSS): 45.0%, mayor que el 98.8% de las vulnerabilidades.
- Solución: actualizar a 1.15.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| fluentd RubyGems | ≥ 1.13.2, < 1.15.3
| 1.15.3
|
| fluentd | ≥ 1.13.2, < 1.15.3
| 1.15.3
|
Description
Impact
A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads.
Fluentd setups are only affected if the environment variable FLUENT_OJ_OPTION_MODE is explicitly set to object.
Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability.
Patches
v1.15.3
Workarounds
Do not use FLUENT_OJ_OPTION_MODE=object.
References
NVD description
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable `FLUENT_OJ_OPTION_MODE` is explicitly set to `object`. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. This issue was patched in version 1.15.3. As a workaround do not use `FLUENT_OJ_OPTION_MODE=object`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free