En resumen
- CVE-2023-0665 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a github.com/hashicorp/vault, vault (hashicorp).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.33%, mayor que el 26.4% de las vulnerabilidades.
- Solución: actualizar a 1.12.5, 1.13.1, 1.11.9 o posterior.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | ≥ 1.12.0, < 1.12.5≥ 1.13.0, < 1.13.1< 1.11.9
| 1.12.51.13.11.11.9
|
| vault | ≥ 1.12.0, < 1.12.5≥ 1.13.0, < 1.13.1< 1.11.9
| 1.12.51.13.11.11.9
|
Description
HashiCorp Vault's PKI mount issuer endpoints did not correctly authorize access to remove an issuer or modify issuer metadata, potentially resulting in denial of service of the PKI mount. This bug did not affect public or private key material, trust chains or certificate issuance. Fixed in Vault 1.13.1, 1.12.5, and 1.11.9.
NVD description
HashiCorp Vault's PKI mount issuer endpoints did not correctly authorize access to remove an issuer or modify issuer metadata, potentially resulting in denial of service of the PKI mount. This bug did not affect public or private key material, trust chains or certificate issuance. Fixed in Vault 1.13.1, 1.12.5, and 1.11.9.
Más vulnerabilidades de github.com/hashicorp/vault
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free