En resumen
- CVE-2023-0872 es una vulnerabilidad ALTO (CVSS 8.0) que afecta a org.opennms:opennms-webapp-rest, horizon (opennms), meridian (opennms).
- Probabilidad de explotación en los próximos 30 días (EPSS): 3.3%, mayor que el 88.6% de las vulnerabilidades.
- Solución: actualizar a 32.0.2 o posterior.
| Package | Affected versions | Patched versions |
|---|
| org.opennms:opennms-webapp-rest Maven | ≥ 31.0.8, < 32.0.2
| 32.0.2
|
| horizon | ≥ 31.0.8, < 32.0.2
| 32.0.2
|
| meridian | ≥ 2020.0.0, ≤ 2020.1.37≥ 2021.0.0, ≤ 2021.1.29≥ 2022.0.0, ≤ 2022.1.18≥ 2023.0.0, ≤ 2023.1.5
| No fix yet |
Description
The Horizon REST API includes a users endpoint in OpenNMS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
OpenNMS thanks Erik Wynter for reporting this issue.
NVD description
The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
OpenNMS thanks Erik Wynter for reporting this issue.
Más vulnerabilidades de org.opennms:opennms-webapp-rest
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free