En resumen
- CVE-2023-2017 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a shopware/core, shopware/platform, shopware (shopware).
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.1%, mayor que el 81.4% de las vulnerabilidades.
- Solución: actualizar a 6.4.20.1 o posterior.
Description
Impact
We fixed with CVE-2023-22731 Twig filters to only be executed with allowed functions. It is possible to pass PHP Closures as string or an array and array crafted PHP Closures was not checked against allow list
Patches
The problem has been fixed with 6.4.20.1 with an improved override.
Workarounds
For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
NVD description
Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in `Shopware\Core\Framework\Adapter\Twig\SecurityExtension` and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified names, supplied as array of strings, when referencing callables. Users are advised to upgrade to v6.4.20.1 to resolve this issue. This is a bypass of CVE-2023-22731.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free