| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/hashicorp/vault | ≥ 1.11.0, < 1.11.8≥ 1.12.0, < 1.12.4< 1.10.11 | 1.11.81.12.41.10.11 |
| vault | ≥ 1.11.0, < 1.11.8≥ 1.12.0, < 1.12.4< 1.10.11 | 1.11.81.12.41.10.11 |
When using the Vault and Vault Enterprise (Vault) approle auth method, any authenticated user with access to the /auth/approle/role/:role_name/secret-id-accessor/destroy endpoint can destroy the secret ID of any other role by providing the secret ID accessor. This vulnerability, CVE-2023-24999, has been fixed in Vault 1.13.0, 1.12.4, 1.11.8, 1.10.11 and above.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free