En resumen
- CVE-2023-28119 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a github.com/crewjam/saml, saml (saml project).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.96%, mayor que el 61.5% de las vulnerabilidades.
- Solución: actualizar a 0.4.13 o posterior.
Description
Our use of flate.NewReader does not limit the size of the input. The user could pass more than 1 MB of data in the HTTP request to the processing functions, which will be decompressed server-side using the Deflate algorithm. Therefore, after repeating the same request multiple times, it is possible to achieve a reliable crash since the operating system kills the process.
NVD description
The crewjam/saml go library contains a partial implementation of the SAML standard in golang. Prior to version 0.4.13, the package's use of `flate.NewReader` does not limit the size of the input. The user can pass more than 1 MB of data in the HTTP request to the processing functions, which will be decompressed server-side using the Deflate algorithm. Therefore, after repeating the same request multiple times, it is possible to achieve a reliable crash since the operating system kills the process. This issue is patched in version 0.4.13.
Más vulnerabilidades de github.com/crewjam/saml
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free