En resumen
- CVE-2023-29197 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a guzzlehttp/psr7, psr-7 (guzzlephp).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.2%, mayor que el 68.6% de las vulnerabilidades.
- Solución: actualizar a 2.4.5, 1.9.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| guzzlehttp/psr7 Packagist | ≥ 2.0.0, < 2.4.5< 1.9.1
| 2.4.51.9.1
|
| psr-7 | ≥ 2.0.0, < 2.4.5< 1.9.1
| 2.4.51.9.1
|
Description
Impact
Improper header parsing. An attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n.
Patches
The issue is patched in 1.9.1 and 2.4.5.
Workarounds
There are no known workarounds.
References
NVD description
guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Affected versions are subject to improper header parsing. An attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. This is a follow-up to CVE-2022-24775 where the fix was incomplete. The issue has been patched in versions 1.9.1 and 2.4.5. There are no known workarounds for this vulnerability. Users are advised to upgrade.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free