| Package | Affected versions | Patched versions |
|---|---|---|
| org.xwiki.platform:xwiki-platform-localization-source-wiki | ≥ 14.0-rc-1, < 14.4.8≥ 14.5, < 14.10.1≥ 4.3-milestone-2, < 13.10.11 | 14.4.814.10.113.10.11 |
| xwiki | ≥ 14.0, < 14.4.8≥ 14.5, < 14.10.1< 13.10.11 | 14.4.814.10.113.10.11 |
It's possible to break many translations coming from wiki pages by creating a corrupted document containing a translation object.
The vulnerability has been patched in XWiki 15.0-rc-1, 14.10.1, 14.4.8, and 13.10.11.
There is no other workaround other than fixing any way to create a document that fail to load.
https://jira.xwiki.org/browse/XWIKI-20460
If you have any questions or comments about this advisory:
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free