En resumen
- CVE-2023-34110 es una vulnerabilidad BAJO (CVSS 2.7) que afecta a flask-appbuilder, flask-appbuilder (flask-appbuilder project).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.68%, mayor que el 52.3% de las vulnerabilidades.
- Solución: actualizar a 4.3.2 o posterior.
Description
Impact
An authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password.
Patches
Fixed on 4.3.2
NVD description
Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.
Más vulnerabilidades de flask-appbuilder
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free