En resumen
- CVE-2023-42810 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a systeminformation (systeminformation), systeminformation.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.2%, mayor que el 82.6% de las vulnerabilidades.
- Solución: actualizar a 5.21.7 o posterior.
Description
Impact
SSID Command Injection Vulnerability
Patches
Problem was fixed with a parameter check. Please upgrade to version >= 5.21.7, Version 4 was not affected
Workarounds
If you cannot upgrade, be sure to check or sanitize parameter strings that are passed to wifiConnections(), wifiNetworks() (string only)
References
See also https://systeminformation.io/security.html
NVD description
systeminformation is a System Information Library for Node.JS. Versions 5.0.0 through 5.21.6 have a SSID Command Injection Vulnerability. The problem was fixed with a parameter check in version 5.21.7. As a workaround, check or sanitize parameter strings that are passed to `wifiConnections()`, `wifiNetworks()` (string only).
Más vulnerabilidades de systeminformation
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free