En resumen
- CVE-2023-48218 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a protected populate (strapi), strapi-plugin-protected-populate.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.60%, mayor que el 48.8% de las vulnerabilidades.
- Solución: actualizar a 1.3.4 o posterior.
Description
Impact
Users are able to bypass the field level security. This means fields that they where not allowed to populate could be populated anyway even in the event that they tried to populate something that they don't have access to.
Patches
This issue has been patched in 1.3.4
Workarounds
None
NVD description
The Strapi Protected Populate Plugin protects `get` endpoints from revealing too much information. Prior to version 1.3.4, users were able to bypass the field level security. Users who tried to populate something that they didn't have access to could populate those fields anyway. This issue has been patched in version 1.3.4. There are no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free