| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.ambari.contrib.views:wfmanager | ≥ 2.7.0, < 2.7.8 | 2.7.8 |
| ambari | ≥ 2.7.0, < 2.7.8 | 2.7.8 |
XML External Entity injection in Apache Ambari versions <= 2.7.7, Users are recommended to upgrade to version 2.7.8, which fixes this issue.
More Details:
Oozie Workflow Scheduler had a vulnerability that allowed for root-level file reading and privilege escalation from low-privilege users. The vulnerability was caused through lack of proper user input validation.
This vulnerability is known as an XML External Entity (XXE) injection attack. Attackers can exploit XXE vulnerabilities to read arbitrary files on the server, including sensitive system files. In theory, it might be possible to use this to escalate privileges.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free