En resumen
- CVE-2023-50727 es una vulnerabilidad MEDIO (CVSS 6.1) que afecta a resque, resque (resque).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.51%, mayor que el 44.0% de las vulnerabilidades.
- Solución: actualizar a 2.6.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| resque RubyGems | < 2.6.0
| 2.6.0
|
| resque | < 2.6.0
| 2.6.0
|
Description
Impact
Reflected XSS can be performed using the current_queue portion of the path on the /queues endpoint of resque-web.
Patches
v2.6.0
Workarounds
No known workarounds at this time. It is recommended to not click on 3rd party or untrusted links to the resque-web interface until you have patched your application.
References
https://github.com/resque/resque/pull/1865
NVD description
Resque is a Redis-backed Ruby library for creating background jobs, placing them on multiple queues, and processing them later. Reflected XSS issue occurs when /queues is appended with /"><svg%20onload=alert(domain)>. This issue has been patched in version 2.6.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free