En resumen
- CVE-2023-50944 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a apache-airflow, airflow (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.98%, mayor que el 62.2% de las vulnerabilidades.
- Solución: actualizar a 2.8.1, 2.8.1rc1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | < 2.8.1< 2.8.1rc1
| 2.8.12.8.1rc1
|
| airflow | < 2.8.1
| 2.8.1
|
Description
Apache Airflow, versions before 2.8.1, have a vulnerability that allows an authenticated user to access the source code of a DAG to which they don't have access. This vulnerability is considered low since it requires an authenticated user to exploit it. Users are recommended to upgrade to version 2.8.1, which fixes this issue.
NVD description
Apache Airflow, versions before 2.8.1, have a vulnerability that allows an authenticated user to access the source code of a DAG to which they don't have access. This vulnerability is considered low since it requires an authenticated user to exploit it. Users are recommended to upgrade to version 2.8.1, which fixes this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free