En resumen
- CVE-2023-51699 es una vulnerabilidad MEDIO (CVSS 6.0) que afecta a github.com/fluid-cloudnative/fluid, fluid (linuxfoundation).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.61%, mayor que el 49.3% de las vulnerabilidades.
- Solución: actualizar a 0.9.3 o posterior.
Description
Impact
OS command injection vulnerability within the Fluid project's JuicefsRuntime can potentially allow an authenticated user, who has the authority to create or update the K8s CRD Dataset/JuicefsRuntime, to execute arbitrary OS commands within the juicefs related containers. This could lead to unauthorized access, modification or deletion of data.
Patches
For users who're using version < 0.9.3 with JuicefsRuntime, upgrade to v0.9.3.
References
Are there any links users can visit to find out more?
Credits
Special thanks to the discovers of this issue:
Xiaozheng Zhang [email protected]
NVD description
Fluid is an open source Kubernetes-native Distributed Dataset Orchestrator and Accelerator for data-intensive applications. An OS command injection vulnerability within the Fluid project's JuicefsRuntime can potentially allow an authenticated user, who has the authority to create or update the K8s CRD Dataset/JuicefsRuntime, to execute arbitrary OS commands within the juicefs related containers. This could lead to unauthorized access, modification or deletion of data. Users who're using versions < 0.9.3 with JuicefsRuntime should upgrade to v0.9.3.
Más vulnerabilidades de github.com/fluid-cloudnative/fluid
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free