En resumen
- CVE-2023-6337 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a github.com/hashicorp/vault, vault (hashicorp).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.79%, mayor que el 56.3% de las vulnerabilidades.
- Solución: actualizar a 1.13.12, 1.14.8, 1.15.4 o posterior.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | ≥ 1.12.0, < 1.13.12≥ 1.14.0, < 1.14.8≥ 1.15.0, < 1.15.4
| 1.13.121.14.81.15.4
|
| vault | ≥ 1.13.0, < 1.13.12≥ 1.14.0, < 1.14.8≥ 1.15.0, < 1.15.4≤ 1.12.0
| 1.13.121.14.81.15.4
|
Description
HashiCorp Vault and Vault Enterprise 1.12.0 and newer are vulnerable to a denial of service through memory exhaustion of the host when handling large unauthenticated and authenticated HTTP requests from a client. Vault will attempt to map the request to memory, resulting in the exhaustion of available memory on the host, which may cause Vault to crash.
Fixed in Vault 1.15.4, 1.14.8, 1.13.12.
NVD description
HashiCorp Vault and Vault Enterprise 1.12.0 and newer are vulnerable to a denial of service through memory exhaustion of the host when handling large unauthenticated and authenticated HTTP requests from a client. Vault will attempt to map the request to memory, resulting in the exhaustion of available memory on the host, which may cause Vault to crash.
Fixed in Vault 1.15.4, 1.14.8, 1.13.12.
Más vulnerabilidades de github.com/hashicorp/vault
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free