En resumen
- CVE-2024-12029 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a invokeai.
- Probabilidad de explotación en los próximos 30 días (EPSS): 6.0%, mayor que el 93.3% de las vulnerabilidades.
- Solución: actualizar a 5.4.3rc1, 5.4.3rc2 o posterior.
| Package | Affected versions | Patched versions |
|---|
| invokeai PyPI | ≥ 5.3.1, < 5.4.3rc1≥ 5.3.1, < 5.4.3rc2
| 5.4.3rc15.4.3rc2
|
Description
A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3rc2.
NVD description
A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free