En resumen
- CVE-2024-2213 es una vulnerabilidad BAJO (CVSS 3.3) que afecta a zenml, zenml (zenml).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.24%, mayor que el 15.6% de las vulnerabilidades.
- Solución: actualizar a 0.56.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| zenml PyPI | < 0.56.3
| 0.56.3
|
| zenml | < 0.56.3
| 0.56.3
|
Description
An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.
NVD description
An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free