En resumen
- CVE-2024-24750 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a undici (nodejs), undici.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.70%, mayor que el 53.2% de las vulnerabilidades.
- Solución: actualizar a 6.6.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| undici | ≥ 6.0.0, < 6.6.1
| 6.6.1
|
| undici npm | ≥ 6.0.0, < 6.6.1
| 6.6.1
|
Description
Impact
Calling fetch(url) and not consuming the incoming body ((or consuming it very slowing) will lead to a memory leak.
Patches
Patched in v6.6.1
Workarounds
Make sure to always consume the incoming body.
NVD description
Undici is an HTTP/1.1 client, written from scratch for Node.js. In affected versions calling `fetch(url)` and not consuming the incoming body ((or consuming it very slowing) will lead to a memory leak. This issue has been addressed in version 6.6.1. Users are advised to upgrade. Users unable to upgrade should make sure to always consume the incoming body.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free