En resumen
- CVE-2024-24758 es una vulnerabilidad MEDIO (CVSS 4.5) que afecta a undici (nodejs), undici.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.77%, mayor que el 55.5% de las vulnerabilidades.
- Solución: actualizar a 6.6.1, 5.28.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| undici | ≥ 6.0.0, < 6.6.1< 5.28.3
| 6.6.15.28.3
|
| undici npm | ≥ 6.0.0, < 6.6.1< 5.28.3
| 6.6.15.28.3
|
Description
Impact
Undici already cleared Authorization headers on cross-origin redirects, but did not clear Proxy-Authorization headers.
Patches
This is patched in v5.28.3 and v6.6.1
Workarounds
There are no known workarounds.
References
NVD description
Undici is an HTTP/1.1 client, written from scratch for Node.js. Undici already cleared Authorization headers on cross-origin redirects, but did not clear `Proxy-Authentication` headers. This issue has been patched in versions 5.28.3 and 6.6.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free