En resumen
- CVE-2024-24811 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a products-sqlalchemyda, sqlalchemyda (zope).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.89%, mayor que el 59.4% de las vulnerabilidades.
- Solución: actualizar a 2.2 o posterior.
Description
Impact
The vulnerability allows unauthenticated execution of arbitrary SQL statements on the database the SQLAlchemyDA instance is connected to. All users are affected.
Patches
The problem has been patched in version 2.2.
Workarounds
There is no workaround. All users are urged to upgrade to version 2.2
NVD description
SQLAlchemyDA is a generic database adapter for ZSQL methods. A vulnerability found in versions prior to 2.2 allows unauthenticated execution of arbitrary SQL statements on the database to which the SQLAlchemyDA instance is connected. All users are affected. The problem has been patched in version 2.2. There is no workaround for the problem.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free