En resumen
- CVE-2024-27296 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a directus (monospace), directus.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.57%, mayor que el 47.1% de las vulnerabilidades.
- Solución: actualizar a 10.8.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| directus | < 10.8.3
| 10.8.3
|
| directus npm | < 10.8.3
| 10.8.3
|
Description
Impact
Currently the exact Directus version number is being shipped in compiled JS bundles which are accessible without authentication. With this information a malicious attacker can trivially look for known vulnerabilities in Directus core or any of its shipped dependencies in that specific running version.
Patches
The problem has been resolved in versions 10.8.3 and newer
Workarounds
None
NVD description
Directus is a real-time API and App dashboard for managing SQL database content. Prior to version 10.8.3, the exact Directus version number was being shipped in compiled JS bundles which are accessible without authentication. With this information a malicious attacker can trivially look for known vulnerabilities in Directus core or any of its shipped dependencies in that specific running version. The problem has been resolved in versions 10.8.3 and newer.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free