En resumen
- CVE-2024-29733 es una vulnerabilidad BAJO (CVSS 2.7) que afecta a apache-airflow-providers-ftp, apache-airflow-providers-ftp (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.63%, mayor que el 50.4% de las vulnerabilidades.
- Solución: actualizar a 3.7.0 o posterior.
Description
Improper Certificate Validation vulnerability in Apache Airflow FTP Provider.
The FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly.
This issue affects Apache Airflow FTP Provider: before 3.7.0.
Users are recommended to upgrade to version 3.7.0, which fixes the issue.
NVD description
Improper Certificate Validation vulnerability in Apache Airflow FTP Provider.
The FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly.
This issue affects Apache Airflow FTP Provider: before 3.7.0.
Users are recommended to upgrade to version 3.7.0, which fixes the issue.
Más vulnerabilidades de apache-airflow-providers-ftp
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free