En resumen
- CVE-2024-29904 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a codeigniter4/framework, codeigniter (codeigniter).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.77%, mayor que el 55.7% de las vulnerabilidades.
- Solución: actualizar a 4.4.7 o posterior.
Description
Impact
A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server.
Patches
Upgrade to v4.4.7 or later. See upgrading guide.
Workarounds
- Disabling Auto Routing prevents a known attack vector in the framework.
- Do not pass invalid values to the
lang() function or Language class.
References
NVD description
CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server. Upgrade to v4.4.7 or later.
Más vulnerabilidades de codeigniter4/framework
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free