En resumen
- CVE-2024-37162 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a zsa (idopesok), zsa.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.29%, mayor que el 21.9% de las vulnerabilidades.
- Solución: actualizar a 0.3.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| zsa | < 0.3.3
| 0.3.3
|
| zsa npm | < 0.3.3
| 0.3.3
|
Description
Impact
All users are impacted. The zsa application transfers the parse error stack from the server to the client in production build mode. This can potentially reveal sensitive information about the server environment, such as the machine username and directory paths. An attacker could exploit this vulnerability to gain unauthorized access to sensitive server information. This information could be used to plan further attacks or gain a deeper understanding of the server infrastructure.
Patches
Yes, this has been pathed on 0.3.3
Workarounds
No way to fix other than the patch.
NVD description
zsa is a library for building typesafe server actions in Next.js. All users are impacted. The zsa application transfers the parse error stack from the server to the client in production build mode. This can potentially reveal sensitive information about the server environment, such as the machine username and directory paths. An attacker could exploit this vulnerability to gain unauthorized access to sensitive server information. This information could be used to plan further attacks or gain a deeper understanding of the server infrastructure. This has been patched on `0.3.3`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free