En resumen
- CVE-2024-38357 es una vulnerabilidad MEDIO (CVSS 6.1) que afecta a TinyMCE, tinymce/tinymce, django-tinymce.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.53%, mayor que el 44.8% de las vulnerabilidades.
- Solución: actualizar a 6.8.4, 7.2.0, 5.11.0, 4.1.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| TinyMCE NuGet | ≥ 6.0.0, < 6.8.4≥ 7.0.0, < 7.2.0< 5.11.0
| 6.8.47.2.05.11.0
|
| tinymce/tinymce Packagist | ≥ 6.0.0, < 6.8.4≥ 7.0.0, < 7.2.0< 5.11.0
| 6.8.47.2.05.11.0
|
| django-tinymce PyPI | < 4.1.0
| 4.1.0
|
| tinymce npm | ≥ 6.0.0, < 6.8.4≥ 7.0.0, < 7.2.0< 5.11.0
| 6.8.47.2.05.11.0
|
Description
Impact
A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content parsing code. This allowed specially crafted noscript elements containing malicious code to be executed when that content was loaded into the editor.
Patches
This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that content within noscript elements are properly parsed.
Fix
To avoid this vulnerability:
- Upgrade to TinyMCE 7.2.0 or higher.
- Upgrade to TinyMCE 6.8.4 or higher for TinyMCE 6.x.
- Upgrade to TinyMCE 5.11.0 LTS or higher for TinyMCE 5.x (only available as part of commercial long-term support contract).
Acknowledgements
Tiny thanks Malav Khatri and another reporter for their help identifying this vulnerability.
References
For more information
If you have any questions or comments about this advisory:
NVD description
TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content parsing code. This allowed specially crafted noscript elements containing malicious code to be executed when that content was loaded into the editor. This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that content within noscript elements are properly parsed. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free