En resumen
- CVE-2024-38988 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a unflatto (alizeait), @alizeait/unflatto.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.87%, mayor que el 59.1% de las vulnerabilidades.
- Solución: actualizar a 1.0.3 o posterior.
Description
Impact
alizeait unflatto <= 1.0.2 was discovered to contain a prototype pollution via the method exports.unflatto at /dist/index.js. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.
Patches
The problem has been patched in 1.0.3
References
https://github.com/advisories/GHSA-799q-f2px-wx8c
NVD description
alizeait unflatto <= 1.0.2 was discovered to contain a prototype pollution via the method exports.unflatto at /dist/index.js. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free