En resumen
- CVE-2024-40761 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a github.com/apache/incubator-answer, answer (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.75%, mayor que el 54.9% de las vulnerabilidades.
- Solución: actualizar a 1.4.0 o posterior.
Description
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.3.5.
Using the MD5 value of a user's email to access Gravatar is insecure and can lead to the leakage of user email. The official recommendation is to use SHA256 instead.
Users are recommended to upgrade to version 1.4.0, which fixes the issue.
NVD description
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.3.5.
Using the MD5 value of a user's email to access Gravatar is insecure and can lead to the leakage of user email. The official recommendation is to use SHA256 instead.
Users are recommended to upgrade to version 1.4.0, which fixes the issue.
Más vulnerabilidades de github.com/apache/incubator-answer
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free