En resumen
- CVE-2024-41674 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a ckan, ckan (okfn).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.38%, mayor que el 32.1% de las vulnerabilidades.
- Solución: actualizar a 2.10.5 o posterior.
| Package | Affected versions | Patched versions |
|---|
| ckan PyPI | ≥ 2.0.0, < 2.10.5
| 2.10.5
|
| ckan | ≥ 2.0, < 2.10.5
| 2.10.5
|
Description
If there were connection issues with the Solr server, the internal Solr URL (potentially including credentials) could be leaked to package_search calls as part of the returned error message
Patches
This has been patched in CKAN 2.10.5 and 2.11.0
NVD description
CKAN is an open-source data management system for powering data hubs and data portals. If there were connection issues with the Solr server, the internal Solr URL (potentially including credentials) could be leaked to package_search calls as part of the returned error message. This has been patched in CKAN 2.10.5 and 2.11.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free