En resumen
- CVE-2024-45033 es una vulnerabilidad ALTO (CVSS 8.1) que afecta a apache-airflow-providers-fab, apache-airflow-providers-fab (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.99%, mayor que el 62.5% de las vulnerabilidades.
- Solución: actualizar a 1.5.2 o posterior.
Description
Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider.
This issue affects Apache Airflow Fab Provider: before 1.5.2.
When user password has been changed with admin CLI, the sessions for that user have not been cleared, leading to insufficient session expiration, thus logged users could continue to be logged in even after the password was changed. This only happened when the password was changed with CLI. The problem does not happen in case change was done with webserver thus this is different from CVE-2023-40273 which was addressed in Apache-Airflow 2.7.0
Users are recommended to upgrade to version 1.5.2, which fixes the issue.
NVD description
Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider.
This issue affects Apache Airflow Fab Provider: before 1.5.2.
When user password has been changed with admin CLI, the sessions for that user have not been cleared, leading to insufficient session expiration, thus logged users could continue to be logged in even after the password was changed. This only happened when the password was changed with CLI. The problem does not happen in case change was done with webserver thus this is different from CVE-2023-40273 https://github.com/advisories/GHSA-pm87-24wq-r8w9 which was addressed in Apache-Airflow 2.7.0
Users are recommended to upgrade to version 1.5.2, which fixes the issue.
Más vulnerabilidades de apache-airflow-providers-fab
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free