En resumen
- CVE-2024-45217 es una vulnerabilidad ALTO (CVSS 8.1) que afecta a org.apache.solr:solr, solr (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.74%, mayor que el 54.7% de las vulnerabilidades.
- Solución: actualizar a 8.11.4, 9.7.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.solr:solr Maven | ≥ 6.6.0, < 8.11.4≥ 9.0.0, < 9.7.0
| 8.11.49.7.0
|
| solr | ≥ 6.6.0, < 8.11.4≥ 9.0.0, < 9.7.0
| 8.11.49.7.0
|
Description
New ConfigSets that are created via a Restore command, which copy a configSet from the backup and give it a new name, are created without setting the "trusted" metadata.
ConfigSets that do not contain the flag are trusted implicitly if the metadata is missing, therefore this leads to "trusted" ConfigSets that may not have been created with an Authenticated request.
"trusted" ConfigSets are able to load custom code into classloaders, therefore the flag is supposed to only be set when the request that uploads the ConfigSet is Authenticated & Authorized.
This issue affects Apache Solr: from 6.6.0 before 8.11.4, from 9.0.0 before 9.7.0. This issue does not affect Solr instances that are secured via Authentication/Authorization.
Users are primarily recommended to use Authentication and Authorization when running Solr. However, upgrading to version 9.7.0, or 8.11.4 will mitigate this issue otherwise.
NVD description
Insecure Default Initialization of Resource vulnerability in Apache Solr.
New ConfigSets that are created via a Restore command, which copy a configSet from the backup and give it a new name, are created without setting the "trusted" metadata.
ConfigSets that do not contain the flag are trusted implicitly if the metadata is missing, therefore this leads to "trusted" ConfigSets that may not have been created with an Authenticated request.
"trusted" ConfigSets are able to load custom code into classloaders, therefore the flag is supposed to only be set when the request that uploads the ConfigSet is Authenticated & Authorized.
This issue affects Apache Solr: from 6.6.0 before 8.11.4, from 9.0.0 before 9.7.0. This issue does not affect Solr instances that are secured via Authentication/Authorization.
Users are primarily recommended to use Authentication and Authorization when running Solr. However, upgrading to version 9.7.0, or 8.11.4 will mitigate this issue otherwise.
Más vulnerabilidades de org.apache.solr:solr
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free