En resumen
- CVE-2024-45592 es una vulnerabilidad MEDIO (CVSS 6.1) que afecta a damienharper/auditor-bundle, auditor-bundle (damienharper).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.45%, mayor que el 39.0% de las vulnerabilidades.
- Solución: actualizar a 5.2.6 o posterior.
Description
Summary
Unescaped entity property enables Javascript injection.
Details
I think this is possible because %source_label% in twig macro is not escaped. Therefore script tags can be inserted and are executed.
PoC
Impact
persistent XSS. JS can be injected and executed.
NVD description
auditor-bundle, formerly known as DoctrineAuditBundle, integrates auditor library into any Symfony 3.4+ application. Prior to version 5.2.6, there is an unescaped entity property enabling Javascript injection. This is possible because `%source_label%` in twig macro is not escaped. Therefore script tags can be inserted and are executed. The vulnerability is fixed in versions 6.0.0 and 5.2.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free