En resumen
- CVE-2024-46993 es una vulnerabilidad MEDIO (CVSS 4.4) que afecta a electron.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.16%, mayor que el 4.7% de las vulnerabilidades.
- Solución: actualizar a 29.3.3, 30.0.3, 28.3.2 o posterior.
| Package | Affected versions | Patched versions |
|---|
| electron npm | ≥ 29.0.0-alpha.1, < 29.3.3≥ 30.0.0-alpha.1, < 30.0.3< 28.3.2
| 29.3.330.0.328.3.2
|
Description
Impact
The nativeImage.createFromPath() and nativeImage.createFromBuffer() functions call a function downstream that is vulnerable to a heap buffer overflow. An Electron program that uses either of the affected functions is vulnerable to a buffer overflow if an attacker is in control of the image's height, width, and contents.
Workaround
There are no app-side workarounds for this issue. You must update your Electron version to be protected.
Patches
For More Information
If you have any questions or comments about this advisory, email us at [email protected].
NVD description
Electron is an open source framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. In versions prior to 28.3.2, 29.3.3, and 30.0.3, the nativeImage.createFromPath() and nativeImage.createFromBuffer() functions call a function downstream that is vulnerable to a heap buffer overflow. An Electron program that uses either of the affected functions is vulnerable to a buffer overflow if an attacker is in control of the image's height, width, and contents. This issue has been patched in versions 28.3.2, 29.3.3, and 30.0.3. There are no workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free