En resumen
- CVE-2024-47178 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a basic-auth-connect (expressjs), basic-auth-connect.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.52%, mayor que el 44.4% de las vulnerabilidades.
- Solución: actualizar a 1.1.0 o posterior.
Description
Impact
basic-auth-connect <1.1.0 uses a timing-unsafe equality comparison that can leak timing information
Patches
this issue has been fixed in basic-auth-connect 1.1.0
References
NVD description
basic-auth-connect is Connect's Basic Auth middleware in its own module. basic-auth-connect < 1.1.0 uses a timing-unsafe equality comparison that can leak timing information. This issue has been fixed in basic-auth-connect 1.1.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free