En resumen
- CVE-2024-47552 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a org.apache.seata:seata-config-core, seata (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.2%, mayor que el 69.3% de las vulnerabilidades.
- Solución: actualizar a 2.2.0 o posterior.
Description
Deserialization of Untrusted Data vulnerability in Apache Seata (incubating).
This issue affects Apache Seata (incubating): from 2.0.0 before 2.2.0.
Users are recommended to upgrade to version 2.2.0, which fixes the issue.
NVD description
Deserialization of Untrusted Data vulnerability in Apache Seata (incubating).
This issue affects Apache Seata (incubating): from 2.0.0 before 2.2.0.
Severity Justification:
The Apache Seata security team assesses the severity of this vulnerability as "Low" due to stringent real-world mitigating factors. First, the vulnerability is strictly isolated to the Raft cluster mode, an optional and non-default feature introduced in v2.0.0, while most users rely on the unaffected traditional architecture. Second, Seata is an internal middleware; communication between TC and RM/TM occurs entirely within trusted internal networks. An attacker would require prior, unauthorized access to the Intranet to exploit this, making external exploitation highly improbable.
Users are recommended to upgrade to version 2.2.0, which fixes the issue.
Más vulnerabilidades de org.apache.seata:seata-config-core
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free