En resumen
- CVE-2024-47875 es una vulnerabilidad MEDIO (CVSS 6.1) que afecta a dompurify (cure53), dompurify.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.1%, mayor que el 66.5% de las vulnerabilidades.
- Solución: actualizar a 3.1.3, 2.5.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| dompurify | ≥ 3.0.0, < 3.1.3< 2.5.0
| 3.1.32.5.0
|
| dompurify npm | ≥ 3.0.0, < 3.1.3< 2.5.0
| 3.1.32.5.0
|
Description
DOMpurify was vulnerable to nesting-based mXSS
fixed by 0ef5e537 (2.x) and
merge 943
Backporter should be aware of GHSA-mmhx-hmjr-r674 (CVE-2024-45801) when cherry-picking
POC is avaible under test
NVD description
DOMPurify is a DOM-only, super-fast, uber-tolerant XSS sanitizer for HTML, MathML and SVG. DOMpurify was vulnerable to nesting-based mXSS. This vulnerability is fixed in 2.5.0 and 3.1.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free