En resumen
- CVE-2024-51493 es una vulnerabilidad MEDIO (CVSS 6.5) que afecta a octoprint, octoprint (octoprint).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.28%, mayor que el 20.6% de las vulnerabilidades.
- Solución: actualizar a 1.10.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| octoprint PyPI | < 1.10.3
| 1.10.3
|
| octoprint | < 1.10.3
| 1.10.3
|
Description
Impact
OctoPrint versions up until and including 1.10.2 contain a vulnerability that allows an attacker that has gained temporary control over an authenticated victim's OctoPrint browser session to retrieve/recreate/delete the user's or - if the victim has admin permissions - the global API key without having to reauthenticate by re-entering the user account's password.
An attacker could use a stolen API key to access OctoPrint through its API, or disrupt workflows depending on the API key they deleted.
Patches
The vulnerability will be patched in version 1.10.3.
Credits
This vulnerability was discovered and responsibly disclosed to OctoPrint by Jacopo Tediosi.
NVD description
OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up until and including 1.10.2 contain a vulnerability that allows an attacker that has gained temporary control over an authenticated victim's OctoPrint browser session to retrieve/recreate/delete the user's or - if the victim has admin permissions - the global API key without having to reauthenticate by re-entering the user account's password. An attacker could use a stolen API key to access OctoPrint through its API, or disrupt workflows depending on the API key they deleted. This vulnerability will be patched in version 1.10.3 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free