| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.27, < 10.1.31≥ 11.0.0-M23, < 11.0.0≥ 9.0.92, < 9.0.96 | 10.1.3111.0.09.0.96 |
| org.apache.tomcat:tomcat-coyote | ≥ 10.1.27, < 10.1.31≥ 11.0.0-M23, < 11.0.0≥ 9.0.92, < 9.0.96 | 10.1.3111.0.09.0.96 |
| tomcat | = 11.0.0≥ 10.1.27, < 10.1.31≥ 9.0.92, < 9.0.96 | 10.1.319.0.96 |
Incorrect object re-cycling and re-use vulnerability in Apache Tomcat. Incorrect recycling of the request and response used by HTTP/2 requests could lead to request and/or response mix-up between users.
This issue affects Apache Tomcat: from 11.0.0-M23 through 11.0.0-M26, from 10.1.27 through 10.1.30, from 9.0.92 through 9.0.95.
Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free