En resumen
- CVE-2024-56201 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a jinja2, jinja (palletsprojects).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.31%, mayor que el 23.5% de las vulnerabilidades.
- Solución: actualizar a 3.1.5 o posterior.
| Package | Affected versions | Patched versions |
|---|
| jinja2 PyPI | ≥ 3.0.0, < 3.1.5
| 3.1.5
|
| jinja | ≥ 3.0.0, < 3.1.5
| 3.1.5
|
Description
A bug in the Jinja compiler allows an attacker that controls both the content and filename of a template to execute arbitrary Python code, regardless of if Jinja's sandbox is used.
To exploit the vulnerability, an attacker needs to control both the filename and the contents of a template. Whether that is the case depends on the type of application using Jinja. This vulnerability impacts users of applications which execute untrusted templates where the template author can also choose the template filename.
NVD description
Jinja is an extensible templating engine. In versions on the 3.x branch prior to 3.1.5, a bug in the Jinja compiler allows an attacker that controls both the content and filename of a template to execute arbitrary Python code, regardless of if Jinja's sandbox is used. To exploit the vulnerability, an attacker needs to control both the filename and the contents of a template. Whether that is the case depends on the type of application using Jinja. This vulnerability impacts users of applications which execute untrusted templates where the template author can also choose the template filename. This vulnerability is fixed in 3.1.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free