En resumen
- CVE-2024-6345 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a setuptools.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.9%, mayor que el 80.1% de las vulnerabilidades.
- Solución: actualizar a 70.0.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| setuptools PyPI | < 70.0.0
| 70.0.0
|
Description
A vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.
NVD description
A vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free