En resumen
- CVE-2025-15504 es una vulnerabilidad MEDIO (CVSS 5.5) que afecta a lief, lief (lief-project), lief.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.27%, mayor que el 18.5% de las vulnerabilidades.
- Solución: actualizar a 0.17.2 o posterior.
| Package | Affected versions | Patched versions |
|---|
| lief PyPI | < 0.17.2
| 0.17.2
|
| lief | < 0.17.2
| 0.17.2
|
| lief crates.io | < 0.17.2
| 0.17.2
|
Description
A security flaw has been discovered in lief-project LIEF up to 0.17.1. Affected by this issue is the function Parser::parse_binary of the file src/ELF/Parser.tcc of the component ELF Binary Parser. The manipulation results in null pointer dereference. The attack must be initiated from a local position. The exploit has been released to the public and may be used for attacks. Upgrading to version 0.17.2 can resolve this issue. The patch is identified as 81bd5d7ea0c390563f1c4c017c9019d154802978. It is recommended to upgrade the affected component.
NVD description
A security flaw has been discovered in lief-project LIEF up to 0.17.1. Affected by this issue is the function Parser::parse_binary of the file src/ELF/Parser.tcc of the component ELF Binary Parser. The manipulation results in null pointer dereference. The attack must be initiated from a local position. The exploit has been released to the public and may be used for attacks. Upgrading to version 0.17.2 can resolve this issue. The patch is identified as 81bd5d7ea0c390563f1c4c017c9019d154802978. It is recommended to upgrade the affected component.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free