En resumen
- CVE-2025-23207 es una vulnerabilidad ALTO (CVSS 7.2) que afecta a katex (katex), katex.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.41%, mayor que el 35.1% de las vulnerabilidades.
- Solución: actualizar a 0.16.21 o posterior.
| Package | Affected versions | Patched versions |
|---|
| katex | ≥ 0.12.0, < 0.16.21
| 0.16.21
|
| katex npm | ≥ 0.12.0, < 0.16.21
| 0.16.21
|
Description
Impact
KaTeX users who render untrusted mathematical expressions with renderToString could encounter malicious input using \htmlData that runs arbitrary JavaScript, or generate invalid HTML.
Patches
Upgrade to KaTeX v0.16.21 to remove this vulnerability.
Workarounds
- Avoid use of or turn off the
trust option, or set it to forbid \htmlData commands.
- Forbid inputs containing the substring
"\\htmlData".
- Sanitize HTML output from KaTeX.
Details
\htmlData did not validate its attribute name argument, allowing it to generate invalid or malicious HTML that runs scripts.
For more information
If you have any questions or comments about this advisory:
NVD description
KaTeX is a fast, easy-to-use JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions with `renderToString` could encounter malicious input using `\htmlData` that runs arbitrary JavaScript, or generate invalid HTML. Users are advised to upgrade to KaTeX v0.16.21 to remove this vulnerability. Users unable to upgrade should avoid use of or turn off the `trust` option, or set it to forbid `\htmlData` commands, forbid inputs containing the substring `"\\htmlData"` and sanitize HTML output from KaTeX.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free