En resumen
- CVE-2025-26467 es una vulnerabilidad ALTO (CVSS 8.8) que afecta a org.apache.cassandra:cassandra-all, cassandra (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.52%, mayor que el 43.9% de las vulnerabilidades.
- Solución: actualizar a 4.0.17, 3.0.31, 3.11.18, 4.1.8 o posterior.
| Package | Affected versions | Patched versions |
|---|
| org.apache.cassandra:cassandra-all Maven | ≥ 4.0.16, < 4.0.17
| 4.0.17
|
| cassandra | ≥ 3.0.0, < 3.0.31≥ 3.11.0, < 3.11.18≥ 4.0.0, < 4.0.17≥ 4.1.0, < 4.1.8≥ 5.0.0, < 5.0.3
| 3.0.313.11.184.0.174.1.85.0.3
|
Description
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches.
This issue affects Apache Cassandra 3.0.30, 3.11.17, 4.0.16, 4.1.7, 5.0.2, but this advisory is only for 4.0.16 because the fix to CVE-2025-23015 was incorrectly applied to 4.0.16, so that version is still affected.
Users in the 4.0 series are recommended to upgrade to version 4.0.17 which fixes the issue. Users from 3.0, 3.11, 4.1 and 5.0 series should follow recommendation from CVE-2025-23015.
NVD description
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches.
This issue affects Apache Cassandra 3.0.30, 3.11.17, 4.0.16, 4.1.7, 5.0.2, but this advisory is only for 4.0.16 because the fix to CVE-2025-23015 was incorrectly applied to 4.0.16, so that version is still affected.
Users in the 4.0 series are recommended to upgrade to version 4.0.17 which fixes the issue. Users from 3.0, 3.11, 4.1 and 5.0 series should follow recommendation from CVE-2025-23015.
Más vulnerabilidades de org.apache.cassandra:cassandra-all
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free