En resumen
- CVE-2025-27018 es una vulnerabilidad MEDIO (CVSS 6.3) que afecta a apache-airflow-providers-mysql, apache-airflow-providers-mysql (apache).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.91%, mayor que el 60.0% de las vulnerabilidades.
- Solución: actualizar a 6.2.0 o posterior.
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider.
When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended.
It could lead to data corruption, modification and others.
This issue affects Apache Airflow MySQL Provider: before 6.2.0.
Users are recommended to upgrade to version 6.2.0, which fixes the issue.
NVD description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider.
When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended.
It could lead to data corruption, modification and others.
This issue affects Apache Airflow MySQL Provider: before 6.2.0.
Users are recommended to upgrade to version 6.2.0, which fixes the issue.
Más vulnerabilidades de apache-airflow-providers-mysql
Ver todo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free